Sierra Wireless Service Disruption Notification (331315)
Incident Report for Status - Sierra Wireless
Resolved
Summary:
Sierra Wireless and our carrier partner identified the issue and took corrective action to restore the service(s) listed below.

Update:
We have been closely monitoring since the corrective action was taken, and have observed no additional impacts within the last hour. We are considering this issue resolved at this time.

Restoration Time:
All services have been restored as of: 10:30 UTC.

Other Information:
We apologize for the service interruption and we thank you for your patience while our teams worked to restore service.
Posted Jul 14, 2020 - 14:23 UTC
Update
Our carrier partner took additional actions to resolve the impact on our services. At this point, all services have recovered to normal performance levels. Due to the severity of this incident, both Sierra and carrier partner teams will continue to monitor closely for an additional hour. If no further issues are identified, we will consider the incident fully resolved.
We recognize the impact this incident has had on our customers and apologize for any inconvenience this service disruption may have caused.
Posted Jul 14, 2020 - 13:16 UTC
Update
Sierra Wireless engineers are continuing to see recoveries after our carrier partner has taken corrective actions to restore services. We will continue to monitor for improvements and provide updates if new developments are available. We will consider this resolved if no further impacts are observed after one hour.
Posted Jul 14, 2020 - 12:02 UTC
Update
Sierra Wireless engineers are continuing to see recoveries after our carrier partner has taken corrective actions to restore services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 11:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 10:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 09:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 08:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 07:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 06:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 05:14 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 04:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 03:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 02:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 01:00 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 14, 2020 - 00:02 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 13, 2020 - 22:53 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 13, 2020 - 21:33 UTC
Update
Our carrier partner has confirmed the network incident resolved, but they are now working through significant backlog/congestion due to the recovery of the outage. Devices are slowly coming back online, but some devices may experience delays in network attachment until this condition is completely mitigated. Our partner carrier is still working vigilantly to stabilize services.
Posted Jul 13, 2020 - 20:02 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 13, 2020 - 18:23 UTC
Update
Sierra Wireless engineers are continuing to see slow recovery after our carrier partner restored services. We will continue to monitor for improvements and provide updates as soon as they are available.
Posted Jul 13, 2020 - 16:43 UTC
Monitoring
Our Carrier Partner has taken action to restore services. We see slow recovery, but continue to monitor for improvements.
Posted Jul 13, 2020 - 14:29 UTC
Update
LTE Data Connectivity has been stable since recovery. Our carrier partner continues to work to restore 2G/3G Data, SMS, Voice, and USSD Services. We will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 13:14 UTC
Update
Our carrier partner is experiencing IP Core and Mobile connectivity failures and is continuing to work to resolve the network outage. 2G/3G Data services remain down, however improvements have been observed in LTE Data Connectivity. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 12:15 UTC
Update
Our carrier partner is experiencing IP Core and Mobile connectivity failures and is continuing to work to resolve the network outage. 2G/3G Data services remain down, however improvements have been observed in LTE Data Connectivity. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 11:15 UTC
Update
Our carrier partner is experiencing IP Core and Mobile connectivity failures and is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 10:15 UTC
Update
Our carrier partner is experiencing IP Core and Mobile connectivity failures and is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 09:15 UTC
Update
Our carrier partner is experiencing IP Core and Mobile connectivity failures and is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 08:15 UTC
Update
Our carrier partner is experiencing IP Core and Mobile connectivity failures and is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 07:15 UTC
Update
Our carrier partner is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 06:15 UTC
Update
Our carrier partner is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 05:15 UTC
Update
Our carrier partner is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 04:15 UTC
Update
Our carrier partner is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 03:15 UTC
Update
Our carrier partner is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 02:15 UTC
Update
Our carrier partner is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 01:15 UTC
Update
Our carrier partner is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 13, 2020 - 00:15 UTC
Update
Our carrier partner is continuing to work to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 12, 2020 - 22:44 UTC
Update
Our carrier partner is continuing to resolve the network outage. Sierra Wireless will continue to provide updates as soon as they are available.
Posted Jul 12, 2020 - 21:34 UTC
Identified
The cause of the service disruption has been isolated to an outage on our partner carrier's network and they are working to resolve as quickly as possible.

No ETR at this time
Posted Jul 12, 2020 - 20:22 UTC
Investigating
Sierra Wireless is currently experiencing a disruption with the services listed below. We are investigating to determine the cause and scope of the impact.

We will provide an update as soon as we have additional information.
Posted Jul 12, 2020 - 19:25 UTC
This incident affected: EasySIM Global (Data (NA), Data (EU), SMS, Voice, USSD).