A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2026 - 15:34 UTC
Identified
The issue has been identified, and a fix is currently being implemented by our carrier partner.
We apologize for any inconvenience caused and appreciate your patience and understanding while the corrective actions are being taken.
Posted Jun 18, 2026 - 12:45 UTC
Update
Our Carrier Partner continues to actively investigate the issue. We are closely coordinating with them and monitoring the situation. Further updates will be shared within the next 2 hours.
We appreciate your patience and understanding.
Posted Jun 18, 2026 - 10:48 UTC
Update
Our Carrier Partner is actively investigating the issue. We are closely coordinating with them and continuously monitoring the situation. Further updates will be shared within the next 2 hours.
Posted Jun 18, 2026 - 08:38 UTC
Investigating
Our monitoring systems have detected service degradation for Subscribers roaming under Carrier Partner Orange France on 4G network only. Most of the device services moved to 2G/3G service, however, few devices are failing to switch. We have reported the issue to our partner carrier, and an investigation to determine the scope and cause is underway.
Impact: Impacted devices may experience degradation in establishing Data, SMS, Voice services and network connectivity.
We appreciate your understanding and will provide the next update within 2 hours.
Posted Jun 18, 2026 - 05:07 UTC
This incident affected: SW Essentials5 (Network Connectivity, Data, SMS, Voice, VoLTE) and SW Advanced (Data (EU)).