A fix has been implemented by our Carrier Partner & we are already observing improvement.
We are now closely monitoring KPIs.
Posted Apr 01, 2026 - 13:39 UTC
Update
Semtech continues to work closely with our partner carrier, regarding the ongoing issue.
Semtech is coordinating with our partner Telenor and Telia, regarding the ongoing issue. Based on the latest discussions, a joint investigation involving all relevant teams is being planned to further analyze and resolve the issue.
At this time, no Estimated Resolution Time (ERT) is available.
Semtech will continue to closely track progress and will provide the next update within the next 6 hours.
Posted Apr 01, 2026 - 08:25 UTC
Update
Semtech continues to work closely with our partner carrier, Telenor, regarding the ongoing issue. Telenor and their supplier are actively investigating and working towards identifying and implementing a resolution. At this time, no Estimated Resolution Time (ERT) is available.
We expect to receive more details during their working hours.
Semtech will continue to monitor the situation closely and will provide the next update within the next 6 hours.
Posted Apr 01, 2026 - 01:32 UTC
Update
Semtech remains in close coordination with our carrier partner, Telenor, who is currently working with their supplier to investigate and resolve the issue. No Estimated Resolution Time (ERT) has been provided yet, though we have formally requested both prioritization and a timeline from Telenor. The case continues to be actively worked on, and we appreciate your patience in the meantime.
We will continue to monitor the situation and provide the next update within the next 6 hours.
Posted Mar 31, 2026 - 19:32 UTC
Update
Semtech continues to work closely with our carrier partner, Telenor, to address the ongoing issue. Telenor, along with their supplier, is actively investigating the matter and working toward identifying and implementing a resolution. At this time, an Estimated Resolution Time (ERT) has not been provided. The case remains under active investigation, and we have formally requested both prioritization and an estimated resolution timeframe from our partner. We appreciate your continued patience as this work progresses. Semtech will continue to monitor the situation closely and will provide the next update within the next six hours, or sooner if new information becomes available.
Posted Mar 31, 2026 - 13:33 UTC
Update
Semtech continues to work closely with our carrier partner, Telenor, to address the ongoing issue. Telenor and their supplier are actively investigating and working toward identifying and implementing a resolution. At this time, no Estimated Resolution Time (ERT) has been provided.
The case remains under investigation, and we have requested both prioritization and an estimated resolution timeframe from our partner. We appreciate your patience while this work progresses.
Semtech will continue to monitor developments closely and will provide the next update within the next 6 hours, or sooner if new information becomes available.
Posted Mar 31, 2026 - 07:28 UTC
Update
Semtech continues to work closely with our partner carrier, Telenor, regarding the ongoing issue. Telenor and their supplier are actively investigating and working towards identifying and implementing a resolution. At this time, no Estimated Resolution Time (ERT) is available. We expect to receive further updates during their working hours.
Semtech will keep tracking progress closely and will share the next update within the next 6 hours.
Posted Mar 31, 2026 - 01:20 UTC
Update
Semtech has further escalated the matter with our partner carrier, Telenor, and raised the incident severity level to expedite resolution. Telenor has carried out a thorough internal network review and confirmed that no issues were detected within their infrastructure. They are presently continuing troubleshooting efforts with their partner team and have provided the relevant logs to assist in identifying the root cause.
Semtech will keep tracking progress closely and will share the next update within the next 6 hours.
Posted Mar 30, 2026 - 19:13 UTC
Update
Semtech has once again escalated the issue with our partner carrier, Telenor, and has increased the incident severity to accelerate resolution. Telenor has completed an extensive internal network investigation and confirmed that no faults were identified within their infrastructure. They are currently continuing troubleshooting activities with their partner team and have shared the relevant logs with them to help determine the root cause of the issue.
Semtech will continue to monitor progress closely and will provide the next update within the next 6 hours.
Posted Mar 30, 2026 - 13:07 UTC
Update
Semtech has coordinated closely with our partner carrier, Telenor, to expedite resolution of the ongoing issue. Telenor has completed an extensive internal network investigation and confirmed that no faults were identified within their infrastructure. They have now escalated the matter to their supplier, who is actively troubleshooting to identify and implement a fix.
Semtech will continue to monitor progress closely and will provide the next update within the next 6 hours.
Posted Mar 30, 2026 - 07:32 UTC
Update
With Semtech’s proactive approach to issue resolution, again, we discussed with the carrier provider. The partner carrier confirmed that they are still experiencing a major issue on their end and are actively working towards a resolution. However, the Estimated Time of Resolution (ETR) is not yet available.
We will continue to closely monitor the situation and provide the next update within the next 6 hours.
Posted Mar 30, 2026 - 01:34 UTC
Update
With Semtech’s proactive approach to issue resolution, again, we discussed with the carrier provider over a call. The partner carrier confirmed that they are still experiencing a major issue on their end and are actively working towards a resolution. However, the Estimated Time of Resolution (ETR) is not yet available.
We will continue to closely monitor the situation and provide the next update within the next 6 hours.
Posted Mar 29, 2026 - 19:29 UTC
Update
With Semtech’s proactive approach to issue resolution, again, we discussed with the carrier provider over a call. The partner carrier confirmed that they are still experiencing a major issue on their end and are actively working towards a resolution. However, the Estimated Time of Resolution (ETR) is not yet available.
We will continue to closely monitor the situation and provide the next update within the next 6 hours.
Posted Mar 29, 2026 - 13:45 UTC
Update
With Semtech’s proactive approach to issue resolution, we held a technical discussion with the carrier provider over a call. The partner carrier confirmed that they are still facing a major issue on their end and are actively working toward resolution. However, the Estimated Time of Resolution (ETR) is still not available.
We will continue to monitor the situation and provide the next update within the next 6 hours.
Posted Mar 29, 2026 - 04:56 UTC
Update
With Semtech’s proactive approach to issue resolution, we conducted a technical discussion with the carrier provider over a call. Our partner carrier has confirmed that they are still experiencing a major issue on their end and are actively working toward resolving it.. However, an Estimated Time of Resolution (ETR) is still not available.
We will continue to closely monitor the situation and share the next update within the next 6 hours.
Posted Mar 28, 2026 - 23:09 UTC
Update
With Semtech’s proactive approach to issue resolution, we held a technical discussion with the carrier provider over a call. The partner carrier confirmed that they are still facing a major issue on their end and are actively working toward resolution. However, the Estimated Time of Resolution (ETR) is still not available.
We will continue to monitor the situation and provide the next update within the next 6 hours.
Posted Mar 28, 2026 - 17:16 UTC
Update
With Semtech’s proactive approach to issue resolution, we conducted a technical discussion with the carrier provider over a call. Our partner carrier has confirmed that they are still experiencing a major issue on their end and are actively working towards a resolution. However, an Estimated Time of Resolution (ETR) is still not available.
We will continue to monitor the situation and provide the next update within the next 6 hours.
Posted Mar 28, 2026 - 10:12 UTC
Update
With Semtech’s proactive approach to issue resolution, we conducted a technical discussion with the carrier provider over a call. Our partner carrier has informed us that they are still experiencing a major issue on their end and are actively working towards a fix. However, they have not yet provided an Estimated Time of Resolution (ETR).
We will provide more updates in the next 6 hours.
Posted Mar 28, 2026 - 02:56 UTC
Update
With Semtech’s proactive approach to issue resolution, we conducted a technical discussion with the carrier provider over a call. Our partner carrier has informed us that they are still experiencing a major issue on their end and are actively working towards a fix. However, they have not yet provided an Estimated Time of Resolution (ETR).
We will provide more updates in the next 6 hours.
Posted Mar 27, 2026 - 20:39 UTC
Update
With Semtech’s proactive approach to issue resolution, we conducted a technical discussion with the carrier provider over a call. Our partner carrier has informed us that they are experiencing a major issue on their end and are actively working towards a fix. However, they have not yet provided an Estimated Time of Resolution (ETR).
We will provide more updates in next 2 hours.
Posted Mar 27, 2026 - 14:25 UTC
Update
Semtech/Sierra Wireless continues to experience a degradation with the Telenor Sweden SMS service. Some customers may still experience difficulties receiving SMS messages originating from Telenor Sweden.
Our team is actively investigating to determine the root cause and full scope of the impact. No Estimated Time to Restore (ETR) is available at this time.
We sincerely appreciate your patience and understanding. A follow-up update will be provided within the next 2 hours.
Posted Mar 27, 2026 - 13:38 UTC
Investigating
Semtech/Sierra Wireless is currently experiencing a degradation with the Telenor Sweden SMS service. As a result, some customers may experience difficulties receiving SMS messages originating from Telenor Sweden.
Our team is actively investigating to determine the root cause and full scope of the impact. No Estimated Time to Restore (ETR) is available at this time.
We sincerely appreciate your patience and understanding. A follow-up update will be provided within the next 2 hours.