Completed
The scheduled maintenance has been completed.
Posted Mar 18, 2026 - 03:31 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2026 - 01:34 UTC
Scheduled
Semtech will be doing an emergency maintenance on its routers in NAM Lithia Springs Data Centers as part of an initiative to improve network resiliency and efficiency. This work aligns with our commitment to providing best-in-class services with Semtech.
Impact: There could be very minor intermittent issues with services routed through Lithia Springs Data Center during the maintenance window. However, we do not anticipate any large scale prolonged impact on our services.
Additional Information: Semtech engineers will be actively monitoring the network throughout the maintenance activity. Notifications will be sent prior to the start of the work and upon completion.
Posted Mar 13, 2026 - 14:14 UTC
This scheduled maintenance affected: SW Advanced (Data (NA), SMS, Voice), SW Essentials3 (Data (NA), SMS, Voice), SW Essentials1 (Data, SMS, Voice), SW Essentials2 (Data, SMS, Voice), SW Essentials4 (Data, SMS, Voice), SW Essentials5 (Data, SMS, Voice), and Enhanced Carrier Connectivity (NAM) / MSO (AT&T - Data, AT&T - SMS, AT&T - Voice, Verizon - Data, Verizon - SMS, Verizon - Voice, Jasper - Data, Jasper - SMS, Rogers - Data, Rogers - SMS, Sprint - Data, Sprint - SMS, Sprint - Voice, T Mobile - Data, T Mobile - SMS, T Mobile - Voice, MES - SMS, Telenor - Data, Telenor - SMS, Xpress (2G Airadigm) - Data, Xpress (2G Airadigm) - SMS).