Service Degradation Notification – LTE Data Connectivity Disturbance in North America (GNOC-7654)

Incident Report for Status - Sierra Wireless

Resolved

Our monitoring tools have shown improved stability for the last several hours. Our internal teams escalated the issue and will continue to work with the partner offline to determine the cause and resolution. We consider this matter closed.

Impact: Subscribed customers may have experienced delays and failures in LTE Data services and network connectivity in the North America region.

We apologize for any inconvenience this may have caused.
Posted Mar 20, 2025 - 23:52 UTC

Monitoring

Our monitoring tools showed a potential partner carrier disturbance in North America that affected LTE Data services and network connectivity for Semtech Smart Connectivity. Our internal teams are engaged with our partner investigating to determine scope and resolution of the issue.

Impact: For less than 30 minutes, subscribed customers may have experienced delays and failures in LTE Data services and network connectivity.

1st network event: 2025-03-20 16:52 - 17:07 UTC
2nd network event: 2025-03-20 17:13 - 17:26 UTC

We will provide an update as soon as we have additional information.
Posted Mar 20, 2025 - 18:20 UTC
This incident affected: SW Essentials3 (Data (NA)), SW Essentials1 (Data), SW Essentials2 (Data), SW Essentials4 (Data), and SW Essentials5 (Network Connectivity, Data).