Service Disruption Notification - IMaestro Platform (GNOC-10312)

Incident Report for Status - Sierra Wireless

Resolved

We have not observed any further issues during our monitoring period. We are considering this issue resolved.
Posted Nov 18, 2025 - 17:44 UTC

Monitoring

Corrective action has been taken to resolve this issue. We are currently monitoring to ensure stability. We will consider this resolved if no further impacts are observed after one hour.
Posted Nov 18, 2025 - 15:58 UTC

Investigating

Semtech/Sierra Wireless is experiencing a disruption with the iMaestro Platform. We are investigating to determine the cause and scope of the impact.

We appreciate your patience in this regard. We will provide the next update within 2 hours.
Posted Nov 18, 2025 - 14:29 UTC
This incident affected: Broadband Access (iMaestro Platform).