Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2025 - 01:00 UTC
Scheduled
Semtech will be upgrading the Firewall cluster to the latest version in one of its geo-redundant data centers. This emergency upgrade aims to enhance network resiliency and efficiency by addressing vulnerabilities in the current version. This work is part of our network lifecycle management process and aligns with our commitment to providing best-in-class services to our customers.
Impact: Despite measures to minimize risk, there may be interruptions in network connectivity affecting Data, Voice, and SMS services. The Firewall is in a failover pair, so we will upgrade the firewalls one at a time. During the activity, disruptions are expected to last no more than 30 minutes.
Other Information: Semtech engineers will actively monitor the network during the maintenance activity. Notifications will be sent before and after the maintenance is completed.
Posted Mar 19, 2025 - 16:10 UTC
This scheduled maintenance affected: Broadband Access (iMaestro Platform) and Enhanced Carrier Connectivity (NAM) / MSO (AT&T - Data, AT&T - SMS, AT&T - Voice, Verizon - Data, Verizon - SMS, Verizon - Voice, Jasper - Data, Jasper - SMS, Rogers - Data, Rogers - SMS, T Mobile - Data, T Mobile - SMS, T Mobile - Voice, MES - SMS, Telenor - Data, Telenor - SMS, Xpress (2G Airadigm) - Data, Xpress (2G Airadigm) - SMS).