Service Degradation Notification – Carrier+ disturbance in Services in NAM region (GNOC-12684)

Incident Report for Status - Sierra Wireless

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 13:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2026 - 12:16 UTC

Update

Our Carrier partner is still actively investigating and working on a fix.
We will provide the next update within the next 2 hours.
Posted Jul 22, 2026 - 11:02 UTC

Update

Our Carrier partner is actively working to fix the issue.

We will provide the next update within the next 2 hours.
Posted Jul 22, 2026 - 08:58 UTC

Investigating

Semtech’s monitoring systems have identified an issue that is impacting Carrier+ services in NAM region. Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible.

Impact: Customers may experience delays or degradation in SMS, Voice, Data sessions, and overall network connectivity.

We will provide the next update within the next two hours.
Posted Jul 22, 2026 - 07:21 UTC
This incident affected: Enhanced Carrier Connectivity (NAM) / MSO (Verizon - Data, Verizon - SMS, Verizon - Voice).