Services were restored, and our teams have observed significant improvements in services and network connectivity, and we will continue to monitor the issue . We will consider this resolved if no further impacts are observed during our monitoring period.
Posted Dec 27, 2025 - 11:36 UTC
Update
We are investigating an issue in North America. We are in the process of engaging the partner to determine the scope and cause of the issue.
Impact: ECC customers may be experiencing failures or degradation in network connectivity and Data services. Smart Connectivity services are unaffected.
We will provide an update as soon as we have additional information.
Posted Dec 27, 2025 - 10:05 UTC
Investigating
We are investigating an issue in North America. We are in the process of engaging the partner to determine the scope and cause of the issue. Impact: ECC customers may be experiencing failures or degradation in network connectivity and Data services. Smart Connectivity services are unaffected.
Posted Dec 27, 2025 - 09:29 UTC
This incident affected: Enhanced Carrier Connectivity (NAM) / MSO (AT&T - Data, AT&T - SMS, AT&T - Voice, Verizon - Data, Verizon - SMS, Verizon - Voice, Rogers - Data, Rogers - SMS, T Mobile - Data, T Mobile - SMS, T Mobile - Voice).