Our partner carrier is engaged and actively working on the issue and we have observed significant improvements on the network for over an hour. Services have been restored, and our engineers are currently monitoring to ensure stability.
We will consider this resolved if no further impacts are observed during our monitoring period.
Posted Jul 03, 2025 - 01:35 UTC
Update
A disruption on a partner's network is affecting Semtech services. Escalations have been made and the partner is engaged to resolve the issue. Customers using Essentials 1 subscription offers primarily in the EU and NAM markets may experience delays and failures in SMS, USSD, Voice, Data service establishment and network connectivity.
Impact: Customer currently using Semtech's Essentials 1 subscription offers may be experiencing delays and failures in SMS, USSD, Voice, Data service establishment and network connectivity. Existing Data sessions are unaffected, however there may be delays establishing new sessions.
We appreciate your patience on this regard. We will provide the next update within 2 hours.
Posted Jul 02, 2025 - 23:27 UTC
Investigating
Our monitoring systems have alerted anomalies to key performance indicators for some Essentials1 SIM subscriptions in the European and North american regions.
- Engineers are actively investigating.
We will provide additional details in 15 minutes.
Posted Jul 02, 2025 - 22:35 UTC
This incident affected: SW Essentials1 (Data, SMS, Voice, USSD).