The scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 22, 2025 - 21:16 UTC
Scheduled
Our Partner Carrier will perform planned maintenance on the switchboard backend system of its exchange service to optimize operations. This activity may cause brief interruptions to Maingate Voice services and individual phone calls. As part of their network lifecycle management process, this work will improve network resiliency and efficiency, aligning with their commitment to providing best-in-class services.
Impact: During the activity, customers may experience momentary disturbances to individual phone calls and Maingate Voice services.
Additional Information: Semtech Global NOC will actively monitor the network during the maintenance activity. Notifications will be sent before and after the completion of the maintenance.
Posted Apr 04, 2025 - 20:12 UTC
This scheduled maintenance affected: Maingate (DNA (Finnish SIMs) - Voice).