This notice is to inform you that the scheduled maintenance has successfully completed. The list below of affected services are back to operational.
We appreciate your patience during the maintenance window.
Posted Oct 28, 2025 - 16:03 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 28, 2025 - 08:01 UTC
Scheduled
Our Partner Carrier will be performing core network maintenance on its roaming infrastructure. This activity is part of the partner’s ongoing network lifecycle management strategy, designed to enhance reliability and improve overall service resiliency for our customers.
Impact: While no service interruptions are anticipated, brief periods of reduced performance may occur. During the maintenance window, some devices may experience temporary delays or disruptions in SMS, Voice, Data services, or overall network connectivity. All necessary precautions have been taken to minimize potential impact.
Additional Information: The Semtech Global NOC will actively monitor network performance throughout the maintenance window. Notifications will be issued prior to the start of the activity and again upon its successful completion.