The incident has been resolved. Our teams will continue to work with our partner offline for a root cause and resolution.
We appreciate your patience and understanding.
Posted Nov 20, 2025 - 20:32 UTC
Monitoring
Services have restored. Our engineers continue to observe improvements in our partner carrier network. Escalations have been made, and the partner engaged to assess and conclude their issue. We are closely monitoring to ensure stability.
Impact: Customers utilizing Semtech’s Essentials 5 subscription in global markets, including Europe and North America, may have experienced brief failures or delays in SMS, Voice, and Data service establishment and network connectivity.
We appreciate your patience and understanding. Further updates will be provided as soon as additional information becomes available.
Posted Nov 20, 2025 - 17:58 UTC
Update
A disruption on a partner’s network may be affecting Semtech services. Our engineers are observing significant improvements and are working with the partner to assess the issue.
Impact: Customers currently using Semtech’s 5 offer may have experienced failures and delays in SMS, Voice, and Data service establishment and network connectivity.
We appreciate your patience in this regard. We will provide an update as soon as we have additional information.
Posted Nov 20, 2025 - 15:28 UTC
Investigating
Our monitoring systems have detected possible service disturbances to Essentials5 SIM subscriptions. Engineers are actively investigating.