Service Degradation Notification for Essentials1 SIM Subscriptions in NAM & EU Region (GNOC-10297)

Incident Report for Status - Sierra Wireless

Resolved

We have not observed any further issues during our monitoring period. We are considering this issue resolved.
Posted Nov 17, 2025 - 21:36 UTC

Monitoring

Our partner carrier has restored service, and our engineers are monitoring it to ensure stability. If no further impacts are observed during our monitoring period, we will consider this resolved.
Posted Nov 17, 2025 - 19:01 UTC

Investigating

Semtech is currently observing a service degradation affecting Essentials1 SIM subscriptions in the Europe and USA regions. Devices operating within these regions may experience difficulties when attempting to establish new data sessions, and a limited number of subscribers may experience drops in existing data sessions. The issue has been reported to our partner carrier, and an investigation is underway to assess the scope and identify the root cause.

Impact: Impacted devices may experience delays in establishing data, SMS, and voice services.

Further updates will be provided as additional information becomes available.
Posted Nov 17, 2025 - 18:06 UTC
This incident affected: SW Essentials1 (Data, SMS, Voice).