In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 09, 2026 - 13:05 UTC
Scheduled
Semtech will be adding new routers in the Lithia Springs Data Center, North America as part of an initiative to improve network resiliency and efficiency. This work aligns with our commitment to providing best-in-class services with Semtech.
Impact: There will be no impact to services. This notification is being provided as the activity involves adding new routers to the production network within the data center. No network degradation is anticipated during the maintenance window. We will be working during only in the NAM business hours, 7 AM EST to 5 PM EST each day.
Additional Information: Semtech engineers will be actively monitoring the network throughout the maintenance activity. Notifications will be sent prior to the start of the work and upon completion.”
Posted Feb 03, 2026 - 14:52 UTC
This scheduled maintenance affects: SW Advanced (Data (NA), SMS, Voice, USSD), SW Essentials3 (Data (NA), Data (EU), SMS, Voice, USSD), SW Essentials1 (Data, SMS, Voice, USSD), SW Essentials2 (Data, SMS, Voice, USSD), SW Essentials4 (Data, SMS, Voice, USSD), SW Essentials5 (Network Connectivity, Data, SMS, USSD, Voice, VoLTE), and Enhanced Carrier Connectivity (NAM) / MSO (AT&T - Data, AT&T - SMS, AT&T - Voice, Verizon - Data, Verizon - SMS, Verizon - Voice, Jasper - Data, Jasper - SMS, Rogers - Data, Rogers - SMS, Sprint - Data, Sprint - SMS, Sprint - Voice, T Mobile - Data, T Mobile - SMS, T Mobile - Voice, MES - SMS, Telenor - Data, Telenor - SMS, Xpress (2G Airadigm) - Data, Xpress (2G Airadigm) - SMS).