Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 24, 2025 - 00:00 UTC
Scheduled
Our partner carrier will be performing scheduled maintenance to migrate a network link to a new router at one of its geo-redundant data centers. This activity is part of their ongoing efforts to improve the security, reliability, and overall performance of services delivered to our valued clients. A list of affected services is provided below.
Impact: During the maintenance window, there may be brief periods of service degradation or interruptions affecting SMS, Voice, Data services, and network connectivity, potentially lasting several minutes at a time.
Additional Information: The Semtech Global Network Operations Center (GNOC) will actively monitor the network throughout the maintenance period. Notifications will be sent out prior to the start and upon completion of the activity.
Posted Sep 18, 2025 - 18:12 UTC
This scheduled maintenance affected: SW Essentials1 (Data, SMS, Voice).