A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2026 - 08:29 UTC
Update
Our carrier partner is currently working on the issue, and we are expecting update shortly. We will provide an update in next 90 minutes .
Posted Mar 27, 2026 - 07:08 UTC
Update
Our Carrier Partner is engaged . We are still continuing to investigate this issue with our carrier partner.
We will provide an update in next 90 minutes .
Posted Mar 27, 2026 - 05:27 UTC
Update
We are continuing to investigate this issue.
Posted Mar 27, 2026 - 03:47 UTC
Investigating
We are currently observing service degradation in Telia Swedish Data Service. We have reported this issue to our partner carrier, and an investigation to determine the scope and cause is underway.
Impact: Some customers may experience connectivity delays or failures in 2G/3G Data sessions.
We appreciate your patience in this regard. We will provide the next update within 2 hours.
Posted Mar 27, 2026 - 03:16 UTC
This incident affected: Maingate (Telia (Swedish SIMs) - Data).